summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuliette Monsel2019-11-07 11:54:09 +0100
committerJuliette Monsel2019-11-07 11:54:09 +0100
commit87e9edf985ab954d7538e403d6620dea3beb56af (patch)
treedc610cbb1c4eeaa4cd7af630b21434bcc4db2eb2 /PKGBUILD
parentbaa267f3af40ac170e816b28dff9e80df42bf263 (diff)
downloadaur-87e9edf985ab954d7538e403d6620dea3beb56af.tar.gz
Patch setup.py to remove sphinx from setup_requires
Sphinx is only needed to build the documentation, which is not done here. Keeping it in the setup_requires array leads to errors when building the python2 package, so to avoid adding sphinx to makedepends I removed it from setup.py.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb2d5642c409..da961e4284fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=('python-pynput' 'python2-pynput')
pkgver=1.4.4
-pkgrel=1
+pkgrel=2
_name=pynput
pkgdesc="Python library to monitor and control user input devices"
arch=('any')
url="https://github.com/moses-palmer/pynput"
license=('LGPL3')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/moses-palmer/${_name}/archive/v${pkgver}.tar.gz")
-sha512sums=('6145aa134e15dcfcaf04ec65c8c05a07b457a78030f8bfed44620bc2590773d3be4707ae619c1afdcb25f0587faf0c8aa932cc0af53aaa999d634f68ce4e5193')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/moses-palmer/${_name}/archive/v${pkgver}.tar.gz"
+ "python-pynput.patch")
+sha512sums=('6145aa134e15dcfcaf04ec65c8c05a07b457a78030f8bfed44620bc2590773d3be4707ae619c1afdcb25f0587faf0c8aa932cc0af53aaa999d634f68ce4e5193'
+ 'fd25744095c3201335cf601ec7e514f4bb2943de777849b2e821168d4e61098ecc355cfa13eb07ede7c1b91fe63f694a1dd42b13b5d4b8796a593aa5acf908b9')
makedepends=('python-setuptools' 'python2-setuptools')
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ patch -Np1 -i "${srcdir}/python-pynput.patch"
+}
+
build() {
cd "$srcdir/${_name}-${pkgver}"
python setup.py build