summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCedric Girard2017-12-11 17:29:17 +0100
committerCedric Girard2017-12-11 17:29:17 +0100
commit762aaa2ec59bb7bcdf7f112bc1c729d2da423552 (patch)
tree6cfd5678198d3ec475f342c22034f6022bed6afc /PKGBUILD
downloadaur-762aaa2ec59bb7bcdf7f112bc1c729d2da423552.tar.gz
python3 version of pynzb
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c23653ae6ca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: vorpalblade77@gmail.com
+# Contributor: Daniel Neve <the.mephit@googlemail.com>
+# Contributor: Eduardo Parra Mazuecos <eduparra90@gmail.com>
+_name=pynzb
+pkgname=python-$_name
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A unified API for parsing NZB files"
+arch=('any')
+url="http://pypi.python.org/pypi/pynzb/"
+license=('BSD')
+depends=('python' 'expat')
+makedepends=('python-distribute')
+conflicts=('pynzb')
+optdepends=('python-lxml: Use lxml instead of expat')
+source=(https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz)
+md5sums=('63c74a36348ac28aa99732dcb8be8c59')
+
+build() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py build
+}
+package() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}