summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJP-Ellis2018-08-13 19:29:53 +0200
committerJP-Ellis2018-08-13 19:29:53 +0200
commit28d82d5f782590078e95ea9dd8816080306a975f (patch)
tree44a397c296e581f0b8d0acff7ecfe380fafde84c /PKGBUILD
downloadaur-28d82d5f782590078e95ea9dd8816080306a975f.tar.gz
Initial commit
Signed-off-by: JP-Ellis <josh@jpellis.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93c0487a9ec7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: JP-Ellis <josh@jpellis.me>
+pkgname=python-pyparser
+_name=${pkgname#python-}
+pkgver=1.0
+pkgrel=1
+pkgdesc="pyparser is a collection of classes to make it easier to parse text data in a pythonic way."
+arch=('any')
+url="https://pypi.org/project/pyparser/"
+license=('GPL')
+depends=('python')
+optdepends=()
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('d1b76e2dabdd2952cadfd545229cc144afee6130bf171a031d5bf53f11b912f5')
+noextract=()
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ sed -i 's/parse==1.6.5/parse>=1.6.5/' requirements.txt
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:set ts=2 sw=2 et: