summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrepo2020-01-14 14:48:13 +0000
committerrepo2020-01-14 14:48:13 +0000
commit0cff18ec21274b659d96eae41ae80b49aee216c1 (patch)
tree6f1d4c2f3812f17dd78e5f68abb0402b12a7c4ca /PKGBUILD
downloadaur-0cff18ec21274b659d96eae41ae80b49aee216c1.tar.gz
Update from repo
See changes at https://gitlab.com/hexchain/repo/commit/ed7640684f6a72e2be2111e276cb457e72c195de
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30badc3572ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: j605
+
+pkgname='python-pyperf'
+pkgver=1.7.0
+pkgrel=1
+pkgdesc='Toolkit to run Python benchmarks'
+url='https://github.com/vstinner/pyperf'
+arch=('any')
+license=('MIT')
+depends=('python' 'python-setuptools' 'python-six')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/vstinner/pyperf/archive/${pkgver}.tar.gz)
+sha256sums=('67caab39f99f34fd6387dd59e63bb498a941d8e2da3cd389fbfc8d4d6bf5e97e')
+
+build() {
+ cd pyperf-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd pyperf-${pkgver}
+ python setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}