summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabien Dubosson2018-03-06 16:59:54 +0100
committerFabien Dubosson2018-03-06 19:18:55 +0100
commit9cd7aa4bc67292cdceaef3561c2b34858ecaf712 (patch)
treeea1ce6ee275c1ff752f9ea343417176d0cafa7c8 /PKGBUILD
parent6e33597ac9e2baab2e2b310e941217a4b5839b21 (diff)
downloadaur-9cd7aa4bc67292cdceaef3561c2b34858ecaf712.tar.gz
New upstream realease 0.2.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2abf6f16676..cf95a8393653 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,19 @@ pkgrel="1"
pkgdesc="Library containing various image processing algorithms"
url="https://github.com/jflesch/libpillowfight"
depends=('python' )
-makedepends=('python' 'python-setuptools')
+makedepends=('python' 'python-setuptools' 'git')
license=('GPL3')
arch=('any')
changelog="ChangeLog"
-source=("https://github.com/jflesch/${_pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('50d3837c227b6153d34b826c0a940809')
+source=("git+https://github.com/jflesch/${_pkgname}#tag=${pkgver}")
+md5sums=('SKIP')
build() {
- cd ${srcdir}/libpillowfight-${pkgver}
- make version
- python setup.py build
+ cd ${srcdir}/${_pkgname}
+ make build
}
package() {
- cd ${srcdir}/libpillowfight-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1
+ cd ${srcdir}/${_pkgname}
+ PIP_ARGS="--root=\"${pkgdir}\" --optimize=1" make install_py
}