summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-08-15 10:36:45 +0200
committerMassimiliano Torromeo2016-08-15 10:36:45 +0200
commit123d70188b819d0e898bc9cef7e31da629fabdda (patch)
tree9f2340e60a766d147aed89a8807852781e5f4d9f /PKGBUILD
downloadaur-123d70188b819d0e898bc9cef7e31da629fabdda.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6fda8506d38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python-pypng
+pkgver=0.0.18
+pkgrel=1
+pkgdesc="Pure Python library for PNG image encoding/decoding"
+arch=(any)
+url="https://github.com/drj11/pypng"
+license=('MIT')
+depends=('python-requests' 'python-six')
+makedepends=('python-setuptools')
+source=("$url/archive/pypng-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir"/pypng-pypng-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pypng-pypng-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+}
+
+sha256sums=('6daa52c8b36c51acd86218353a7147692ade70ba2f25b124fbc56ffe3b8ca4df')