summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s2017-11-12 11:01:28 -0500
committerbrent s2017-11-12 11:01:28 -0500
commitf66644cea260d72c503bf648aad0da0c751b10ec (patch)
tree66176564a0da33b11fc0f3402abc0ab92c9471db /PKGBUILD
parente7d8572a91d80c87d55c0386de96efbfbc470691 (diff)
downloadaur-python-pyqrcode.tar.gz
updating for better split-pkg support - thanks, ad1217!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbd111a44cec..76a2a73474bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,15 @@
validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
-pkgname=python-pyqrcode
+pkgname=('python-pyqrcode' 'python2-pyqrcode')
pkgver=1.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="A QR code generator written purely in Python with SVG, EPS, PNG and terminal output (fixed for python3)"
-arch=( 'i686' 'x86_64' )
+arch=('any')
url="https://pythonhosted.org/PyQRCode/"
license=('CUSTOM')
-depends=('python' 'python2')
-optdepends=('python-pypng: PNG generation support' 'python2-pypng: PNG generation support')
-makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools' 'python2-setuptools')
_pkgname=PyQRCode
-install=
-changelog=
-noextract=()
source=("https://files.pythonhosted.org/packages/source/P/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
"LICENSE"
"${_pkgname}-${pkgver}.tar.gz.sig"
@@ -27,6 +22,7 @@ sha512sums=('784262cb15c10f3581b0caeac6bba046686b35b8c0709ee78684b805b6cba49f425
package_python-pyqrcode() {
depends=('python')
+ optdepends=('python-pypng: PNG generation support')
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
@@ -35,6 +31,7 @@ package_python-pyqrcode() {
package_python2-pyqrcode() {
depends=('python2')
+ optdepends=('python2-pypng: PNG generation support')
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1