summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2022-11-17 09:40:44 +0100
committerAntonio Rojas2022-11-17 09:40:44 +0100
commit09edbce3b041f82fb88ca47f0c29efbd8f698471 (patch)
tree5b6f4fa19b817ef5c85ef3fa2c81ada888e673e7 /PKGBUILD
downloadaur-09edbce3b041f82fb88ca47f0c29efbd8f698471.tar.gz
Split from PyQt5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d630d4c92f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer:
+
+pkgname=python-pyqt5-webkit
+pkgdesc="Python bindings for the Qt5WebKit"
+pkgver=5.15.7
+pkgrel=3
+arch=(x86_64)
+url="https://riverbankcomputing.com/software/pyqt/intro"
+license=(GPL)
+groups=(pyqt5)
+depends=(python-pyqt5 qt5-webkit)
+makedepends=(sip pyqt-builder)
+source=("https://pypi.python.org/packages/source/P/PyQt5/PyQt5-$pkgver.tar.gz")
+sha256sums=('755121a52b3a08cb07275c10ebb96576d36e320e572591db16cfdbc558101594')
+options=(debug)
+
+build() {
+ cd PyQt5-$pkgver
+ sip-build \
+ --confirm-license \
+ --no-make \
+ --api-dir /usr/share/qt/qsci/api/python \
+ --pep484-pyi \
+ --enable QtCore \
+ --enable QtWebKit \
+ --enable QtWebKitWidgets
+ cd build
+ make
+}
+
+package(){
+ cd PyQt5-$pkgver/build
+ make INSTALL_ROOT="$pkgdir" install -j1
+
+ # Remove files provided by pyqt5:
+ rm -r "$pkgdir"/usr/{bin,share,lib/python*/site-packages/{*.dist-info,PyQt5/{QtCore.*,bindings/QtCore,uic,sip.pyi,py.typed,__init__.py}}}
+
+ # compile Python bytecode
+ python -m compileall -d / "$pkgdir"/usr/lib
+ python -O -m compileall -d / "$pkgdir"/usr/lib
+}