summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShao-yu Tseng2024-11-27 14:15:27 -0500
committerShao-yu Tseng2024-11-27 14:15:27 -0500
commit1208b5fb9645628e73669bf701c2d671f99a9115 (patch)
tree18de0073ad23953d2012aabf0b62bebac66d86de /PKGBUILD
downloadaur-1208b5fb9645628e73669bf701c2d671f99a9115.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8577bb8fd5fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=python-pyqtdarktheme-fork
+_name=pyqtdarktheme_fork
+pkgver=2.3.2
+pkgrel=3
+pkgdesc='Flat dark theme for PySide and PyQt'
+arch=('any')
+url='https://pypi.org/project/pyqtdarktheme-fork'
+license=('MIT')
+depends=('python')
+optdepends=()
+makedepends=('python-build' 'python-installer' 'python-wheel' 'poetry' 'python-darkdetect')
+provides=('pyqtdarktheme')
+conflicts=('python-pyqtdarktheme')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('3ea94fed5df262d960378409357c63032639f749794d766f41a45ad8558b2523')
+
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}