summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKenneth Lyons2015-10-22 00:44:11 -0700
committerKenneth Lyons2015-10-22 00:44:11 -0700
commitc46bec0a865ff77d4888ba92c56acf3075f0f22c (patch)
tree236dd39c6ce9fbe6760832a9a1837bb1058b4beb /PKGBUILD
downloadaur-python-pyqtgraph-git.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..709d6e181a4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kenneth Lyons (ixjlyons) <ixjlyons@gmail.com>
+
+pkgname=python-pyqtgraph-git
+pkgver=0.9.10.r953.g1036edf
+pkgrel=1
+pkgdesc='Scientific Graphics and GUI Library for Python'
+arch=('any')
+url='https://github.com/pyqtgraph/pyqtgraph'
+license=('MIT')
+depends=('python' 'python-pyqt5' 'python-numpy')
+optdepends=('python-opengl')
+makedepends=('git')
+provides=('python-pyqtgraph')
+conflicts=('python-pyqtgraph')
+source=(${pkgname}::'git+https://github.com/pyqtgraph/pyqtgraph.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "%s.r%s.g%s" "$(grep __version__ pyqtgraph/__init__.py | head -1 | cut -d"'" -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize 1
+}