summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBatuhan Baserdem2020-01-15 21:16:48 -0500
committerBatuhan Baserdem2020-01-15 21:16:48 -0500
commit4b3e83de3184c53cc4fb2c6c368a3837efb46e7b (patch)
treee4afba870fd8b402d16b3c851ef872d3fb985994 /PKGBUILD
parent240089bbcdf235d5797a6a9335bbc446f8c04497 (diff)
downloadaur-4b3e83de3184c53cc4fb2c6c368a3837efb46e7b.tar.gz
Fixed the testing suite, should work.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b92190a8a8a..a3d8cd076431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,10 @@ build() {
check(){
cd "${srcdir}/${_srcname}"
- pytest
+ python setup.py install --root="${srcdir}/${_srcname}/tmp_install"
+ pysys="$(python -c 'import sys; print(sys.version_info.minor)')"
+ pydir="${srcdir}/${_srcname}/tmp_install/usr/lib/python${pysys}/site-packages"
+ PYTHONPATH="${pydir}:${PYTONPATH}"pytest
}
package() {