summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroldherl2024-04-16 17:36:40 +1000
committeroldherl2024-04-16 17:36:40 +1000
commit43e224a3616f380a73242db964d92dd3a7530545 (patch)
treee7fa3116477b21170a3dcf9ad30e98e2a14d3b9c /PKGBUILD
parent6d583b378ca348bfea026dd18bf4b1e6669647d0 (diff)
downloadaur-43e224a3616f380a73242db964d92dd3a7530545.tar.gz
update to 0.22.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba242737bcfb..79143cdcf25f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
#!/bin/bash
-
-# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
+# Maintainer: oldherl <oldherl@gmail.com>
+# Contributor: PumpkinCheshire <me at pumpkincheshire dot com>
# Contributor: Fabio Zanini <fabio.zanini _at_ stanford.edu>
pkgname=python-pysam
_name=pysam
-pkgver=0.18.0
+pkgver=0.22.0
pkgrel=1
pkgdesc='Python interface for the SAM/BAM sequence alignment and mapping format'
arch=('x86_64')
@@ -20,13 +20,14 @@ makedepends=(
provides=('python-pysam')
options=(!emptydirs)
source=("https://github.com/pysam-developers/${_name}/archive/v${pkgver}.tar.gz")
-b2sums=('bc38e5dc0c7714001ead895d01e18063fedb2da5c4c1d907c0d832da19924f5c7a3c65bf85e7148cbc0c3f37317a56e82e06bc7850c11d971bd22757433b74f5')
+sha1sums=(SKIP)
build() {
cd "$srcdir/$_name-$pkgver"
export HTSLIB_LIBRARY_DIR=/usr/lib
export HTSLIB_INCLUDE_DIR=/usr/include
+ export FORCE_CYTHON=1
python setup.py build
}