summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpadfoot2015-07-19 08:17:19 +1000
committerpadfoot2015-07-19 08:17:19 +1000
commitb2d4fee86d667ef9e812aff8798f6438be6eecd7 (patch)
tree509238f080558cdad17dd12d004d7a6e35c3aaee /PKGBUILD
downloadaur-b2d4fee86d667ef9e812aff8798f6438be6eecd7.tar.gz
Version 0.9.3-1: Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..841a7f7d3406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: feuri <padfoot at exemail dot com dot au>
+# Contributor: feuri <mail at feuri dot de>
+
+pkgname=python-pysdl2
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="A Python wrapper around the SDL2 library"
+
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/marcusva/py-sdl2/overview"
+license=('custom:CC0')
+
+depends=('python' 'sdl2')
+optdepends=('sdl2_gfx' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf')
+
+source=(https://bitbucket.org/marcusva/py-sdl2/downloads/PySDL2-${pkgver}.tar.gz)
+md5sums=('0ee011fdb68c0c04753cac11f97c8f9d')
+
+build() {
+ cd "${srcdir}/PySDL2-${pkgver}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${srcdir}/PySDL2-${pkgver}"
+ python3 setup.py install --root="${pkgdir}"
+ install -m 644 -D doc/copying.rst ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}