summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-05 17:17:38 -0600
committerLuis Martinez2022-03-05 17:17:38 -0600
commitcb3190afffc0dad77156631c70768b5e7a692c42 (patch)
tree32c1f7b2ca9738e0a8e4c0ad027663af165b66a4 /PKGBUILD
parentac863a41bd6eae2fbe2b670535e2dd9dc29b65e4 (diff)
downloadaur-python-pyshortcuts.tar.gz
update to 1.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82a6a3dc97de..9a3699712e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-pyshortcuts
-pkgver=1.8.1
+pkgver=1.8.2
pkgrel=1
pkgdesc="Create desktop shortcuts to Python scripts"
arch=('any')
@@ -12,30 +12,27 @@ depends=('python')
makedepends=(
'python-setuptools-scm'
'python-build'
- 'python-install'
+ 'python-installer'
'python-wheel')
optdepends=('python-wxpython: for GUI')
source=(
"$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pyshortcuts/pyshortcuts-$pkgver.tar.gz"
"PyShortcut.desktop")
-sha256sums=('5791056a57f5dc71225afa99838c13354ba00d05568f0e069bb59c2376cc6701'
+sha256sums=('089fb9fb7f3616e30c794dc90af8498718107e40a34b335234a88393db1d400a'
'c243510caaf511a17ee62c89080dfa386a9d2de36eaa937c56de5a97c228ec82')
build() {
cd "pyshortcuts-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
- # python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
export PYTHONHASHSEED=0
cd "pyshortcuts-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
- # python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
- # install -Dm644 pyshortcuts/icons/ladder.png -t "$pkgdir/usr/share/icons/hicolor/512x512/apps/pyshortcuts.png"
install -Dm644 pyshortcuts/icons/ladder.png "$pkgdir/usr/share/pixmaps/pyshortcuts.png"
install -Dm644 "$srcdir/PyShortcut.desktop" -t "$pkgdir/usr/share/applications/"
}