summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Albers2023-05-08 18:38:24 +0200
committerDaniel Albers2023-05-08 18:38:24 +0200
commit3cb9d8f83621f70f9d081a8adeeaf81ef62b6dc8 (patch)
treedb638fff0f1292cc4362aff91825f0af873141be /PKGBUILD
downloadaur-3cb9d8f83621f70f9d081a8adeeaf81ef62b6dc8.tar.gz
0.7.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09f7de555b05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=python-pysma
+pkgver=0.7.4
+_pypiname=${pkgname#python-}
+pkgrel=1
+pkgdesc="Async library for SMA Solar's WebConnect interface"
+arch=(any)
+url="https://github.com/kellerza/pysma"
+license=(Apache-2.0)
+makedepends=("python" "python-pip")
+depends=("python-jmespath")
+
+build() {
+ pip install --no-deps --target="${_pypiname}" ${_pypiname}==${pkgver}
+}
+
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/${_pypiname}/* $pkgdir/"$sitepackages"
+}