summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Dott2020-02-26 00:35:19 +0100
committerGuillaume Dott2020-02-26 00:37:19 +0100
commita222b402cfa7e35e55e3ac0bfe3e25bfab874c39 (patch)
tree46ffe3f24948ab455516801670743094f74d83b0 /PKGBUILD
downloadaur-a222b402cfa7e35e55e3ac0bfe3e25bfab874c39.tar.gz
Add PKGBUILD for version 0.7.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8818de0ffb39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+#Maintainer: Guillaume Dott <guillaume+github at dott dot fr>
+
+pkgname=python-pysonic
+pkgver=0.7.7
+pkgrel=1
+pkgdesc="A python library to wrap the Subsonic REST API"
+arch=('any')
+url="https://github.com/crustymonkey/py-sonic"
+license=('GPL3')
+depends=(
+ 'python-setuptools')
+makedepends=('python')
+provides=('python-pysonic')
+source=("https://github.com/crustymonkey/py-sonic/archive/${pkgver}.tar.gz")
+sha256sums=('2de521d5c79d73025f32ac261ab581bdef1e100c00e7fd0d8992310af662d998')
+
+package() {
+ cd "$srcdir/py-sonic-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}