summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2020-03-17 10:10:21 +1100
committerRhinoceros2020-03-17 10:10:21 +1100
commitac68073764eac7bf60b38b7533008d78545975ee (patch)
tree3aa20020179935a8f1561434a827a55d578a2705 /PKGBUILD
parent0b2265ada904da4efd5765edbaa2798d5f428fb4 (diff)
downloadaur-ac68073764eac7bf60b38b7533008d78545975ee.tar.gz
Update to 1.0.3-2
* Fix pkgbase/pkgname so package builds * Add dependency on sqlcipher, so it builds * Correct pkgdesc as per upstream * Use sha256sums instead of md5sums * Minor style fixes; remove extraneous code * Bump pkgrel
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6b01fd1b71f..eff0789d88a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-pkgbase=('python-pysqlcipher3')
-pkgname=('python-pysqlcipher3')
-_module='pysqlcipher3'
-pkgver='1.0.3'
-pkgrel=1
-pkgdesc="DB-API 2.0 interface for SQLCIPHER 3.x"
-url="https://github.com/rigglemania/pysqlcipher3"
-depends=('python')
+# Contributor: RcrdBrt
+# Contributor: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+
+pkgname=python-pysqlcipher3
+_pkgname=${pkgname#python-}
+pkgver=1.0.3
+pkgrel=2
+pkgdesc='Python 3 bindings for SQLCipher'
+arch=('any')
+url='https://github.com/rigglemania/pysqlcipher3'
+depends=('python' 'sqlcipher')
makedepends=('python-setuptools')
license=('ZLIB')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/p/pysqlcipher3/pysqlcipher3-${pkgver}.tar.gz")
-md5sums=('636368cab1f64db3572255b10e3cb9e3')
+source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('694e5bbb6ece8a064bd55f261e54b9ffbb3af1784afdc4dce4948a0251a8a430')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}