summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKr1ss2021-05-06 16:37:34 +0200
committerKr1ss2021-05-06 16:37:34 +0200
commit7738a59d398b70b57cf4e85746af2e0853764137 (patch)
tree84516ece6794373c4ece32085d85b5781600f0dd /PKGBUILD
parent9544c638f372c24f6077145b3e108fa6ebb2b5d4 (diff)
downloadaur-7738a59d398b70b57cf4e85746af2e0853764137.tar.gz
disable python's hash randomization
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 695fc6c0a3f6..1d13bc78b1b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,16 @@
pkgname=python-pystache-git
-_pkgname="pystache"
+_name=pystache
epoch=1
-pkgver() {
- cd "$_pkgname"
- git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
-}
+pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'; }
pkgver=0.5.4.r3.17a5dfd
-pkgrel=4
+pkgrel=5
pkgdesc="The mustache template engine written in python"
arch=('x86_64')
-url="https://github.com/defunkt/$_pkgname"
+url="https://github.com/defunkt/$_name"
license=('MIT')
provides=('python-pystache')
@@ -29,8 +26,9 @@ changelog=history
source=("git+$url#branch=master")
sha256sums=('SKIP')
+
build() {
- cd "$_pkgname"
+ cd "$_name"
python setup.py build
}
@@ -39,7 +37,7 @@ check() {
# So we need to jump through some hoops here
rm -rf test_dir
mkdir test_dir
- cd "$_pkgname"
+ cd "$_name"
python setup.py install --root=../test_dir
_py3ver="$(python -V | sed 's/Python \(3\.[0-9]\+\).*/\1/')"
PYTHONPATH="../test_dir/usr/lib/python$_py3ver/site-packages/" \
@@ -47,10 +45,11 @@ check() {
}
package() {
- cd "$_pkgname"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_pkgname/"
- install -Dm644 {README,HISTORY}.md setup_description.rst -t"$pkgdir/usr/share/doc/$_pkgname/"
+ cd "$_name"
+ PYTHONHASHSEED=0 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t"$pkgdir/usr/share/licenses/$_name/"
+ install -Dm644 {README,HISTORY}.md setup_description.rst -t"$pkgdir/usr/share/doc/$_name/"
}
+
# vim: sw=4 ts=4 noet ft=PKGBUILD: