summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpiernov2022-06-10 19:00:43 +0200
committerpiernov2022-06-10 19:00:43 +0200
commitaa2c7145bfff4f2c2062bbfacd28e617c5cb8472 (patch)
tree727beae23a4fe4d53a6b16d1c7eb3f7916961fd5 /PKGBUILD
downloadaur-aa2c7145bfff4f2c2062bbfacd28e617c5cb8472.tar.gz
python-pystiche 1.0.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9a1f517be3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: piernov <piernov@piernov.org>
+
+pkgname=python-pystiche
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Framework for Neural Style Transfer (NST) built upon PyTorch"
+arch=('any')
+url="https://github.com/pystiche/pystiche"
+license=('BSD')
+depends=('python-pytorch' 'python-torchvision' 'python-pillow' 'python-tqdm')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools-scm')
+source=("git+https://github.com/pystiche/pystiche.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir"/pystiche
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir"/pystiche
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}