summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2022-01-31 20:41:29 -0500
committerAdam Goldsmith2022-01-31 20:41:29 -0500
commit1cfa73a39642d584c8201f7a08e4b7cea4772d64 (patch)
treef5af7d6d501453b3f8e0f956c492a7f228afd369 /PKGBUILD
parentf36301ab6ce30a365bc0afcac62c6c245d284b66 (diff)
downloadaur-1cfa73a39642d584c8201f7a08e4b7cea4772d64.tar.gz
Patch setup.py to build with fixed module name and no RPATH
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2286348b84ac..41d2eda436c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,19 @@ depends=('apr' 'python' 'subversion')
makedepends=('python-pycxx' 'python-setuptools')
arch=('i686' 'x86_64')
license=('Apache')
-source=("https://downloads.sourceforge.net/project/pysvn/pysvn/V${pkgver}/pysvn-${pkgver}.tar.gz")
-sha256sums=('0906b177578232b267d0102f284823e89bcbcf2dacfe958a989a41d74f0027d3')
+source=("https://downloads.sourceforge.net/project/pysvn/pysvn/V${pkgver}/pysvn-${pkgver}.tar.gz"
+ "fix-setup.py.patch")
+sha256sums=('0906b177578232b267d0102f284823e89bcbcf2dacfe958a989a41d74f0027d3'
+ '59b56272570bdf957570cafb57680a4516f8f0dfbf94c301f133410130b0a8be')
prepare() {
cd "$_name-$pkgver"
# Remove bundled libs
rm -rf Import
+
+ # build with fixed module name and no RPATH
+ patch -p1 -i "$srcdir/fix-setup.py.patch"
}
build() {