summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:19:45 +1300
committercaltlgin2020-12-03 09:19:45 +1300
commitcd9659c05d45e1286c9484d86f33cf0e3545b642 (patch)
treef84bf16181a63f0b2af74080bd9b0513438b4df7 /PKGBUILD
parent2ad1e5c3412cfa18ed7a6a97e94fadfe002f6532 (diff)
downloadaur-cd9659c05d45e1286c9484d86f33cf0e3545b642.tar.gz
Python 3.9 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b722be691a7..2f1abccd99bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_pkgname='pytablewriter'
pkgname="python-${_pkgname}"
pkgver=0.58.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python library to write a table in various formats'
arch=('any')
url='https://github.com/thombashi/pytablewriter'
+_url_pypi='https://pypi.org/project/pytablewriter'
license=('MIT')
-depends=('python'
- 'python-dataproperty'
+depends=('python-dataproperty'
'python-mbstrdecoder'
'python-msgfy'
'python-pathvalidate'
@@ -18,7 +18,6 @@ depends=('python'
'python-tcolorpy'
'python-typepy')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('d232491e32fc84f28a6217fcd225d2ed82ae59d576d39724c98fdb7c7147b9ec')
@@ -30,8 +29,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: