summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-09-04 15:46:57 -0500
committerCarlos Aznarán Laos2022-09-04 15:46:57 -0500
commit4499fadb458c64563fcf98434e7dfa4485f493c9 (patch)
tree17a4cecea225dc0924b52825c7ff2849bad74fc3 /PKGBUILD
parentcff7ad6b186c6242cdf556d9d235ff1b2fa267f6 (diff)
downloadaur-4499fadb458c64563fcf98434e7dfa4485f493c9.tar.gz
Follow the PEP 517 guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 20 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b178ba2fecaa..d7ef65105ba2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,40 @@
_base=pytaglib
pkgname=python-${_base}
pkgver=1.5.0
-pkgrel=3
+pkgrel=4
pkgdesc="Python audio tagging library"
arch=(x86_64)
url="https://github.com/supermihi/${_base}"
license=(GPL3)
depends=(python taglib)
-makedepends=(python-setuptools cython)
+makedepends=(python-build python-install python-setuptools python-wheel)
checkdepends=(python-pytest)
source=(${url}/archive/v${pkgver}.tar.gz)
sha512sums=('1be63e285980b140312aa780a56edf59467ad05aa49b3679d4140a856d07950842e9563ae7783010084e6d82c89b8776bbac94101326f67d041faa410f756556')
build() {
- cd "${_base}-${pkgver}"
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "${_base}-${pkgver}"
- local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}{sys.version_info.minor}')")
- PYTHONPATH="${PWD}/build/lib.linux-${CARCH}-cpython-${_pyversion}:${PYTHONPATH}" python -m pytest tests
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m install --optimize=1 dist/*.whl
+ chmod +x test-env/bin/pyprinttags
+ test-env/bin/python -m pytest tests
}
package() {
- cd "${_base}-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+
+ # https://github.com/FFY00/python-install/pull/6
+ chmod +x ${pkgdir}/usr/bin/pyprinttags
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}