summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpetervaro2017-02-27 21:44:47 +0000
committerpetervaro2017-02-27 21:44:47 +0000
commita18973abe38ace6bd8148c17c6c589661af69756 (patch)
tree91f1ceea32671adb2e0d846ab1326a061cf06fc3 /PKGBUILD
downloadaur-a18973abe38ace6bd8148c17c6c589661af69756.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..973783eb241b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Peter Varo <hello@petervaro.com>
+
+pkgname=python-pyte-git
+pkgver=r237.211541f
+pkgver() {
+ cd "pyte"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+pkgrel=1
+pkgdesc="Simple VTXXX-compatible linux terminal emulator"
+arch=('any')
+url="https://github.com/selectel/pyte"
+license=('LGPL3')
+depends=('python')
+makedepends=('git' 'python-distribute')
+conflicts=('python-pyte')
+source=("git://github.com/selectel/pyte.git")
+sha256sums=('SKIP')
+
+build() {
+ cd pyte
+ python setup.py build
+}
+
+package() {
+ cd pyte
+ python setup.py install --root="$pkgdir" --optimize=1
+}