summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2021-07-23 10:02:42 +0200
committerXiretza2021-07-23 10:02:42 +0200
commit5cd869f345bfa7678fd48d0ed94b5e28f8183ccf (patch)
tree7d2ac33684150fdb227ac913127b9b7b77d4fb6d /PKGBUILD
parent33168304c2d323669799f91d9b3ab3c30cb3094f (diff)
downloadaur-5cd869f345bfa7678fd48d0ed94b5e28f8183ccf.tar.gz
Update to 1.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b309c65c5fe9..81d3d32fb430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname='pyTerminalUI'
pkgname=python-${_pkgname,,}
-pkgver=1.3.4
+pkgver=1.4.1
pkgrel=1
pkgdesc="A set of helpers to implement a text user interface (TUI) in a terminal"
arch=(any)
url="https://github.com/Paebbels/pyTerminalUI"
license=('Apache')
-depends=('python-colorama' 'python-pyexceptions' 'python-pymetaclasses')
+depends=('python' 'python-colorama' 'python-pydecor' 'python-pyexceptions' 'python-pymetaclasses')
makedepends=('python-setuptools')
checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('75843183d41e6696352a29a18ea97a3b66ef2c82cf0bc70b68c78e0a0a6126ec')
+sha256sums=('50331ed201df0de08213db19da75276862d82faeb1c5a241c5d8a1614dfeffb4')
build() {
cd "$_pkgname-$pkgver"
@@ -21,8 +21,7 @@ build() {
check(){
cd "$_pkgname-$pkgver"
- touch tests/__init__.py
- pytest --override-ini 'python_files=*' tests/
+ pytest tests/
}
package() {