summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVampireSH2017-03-29 22:13:12 +0800
committerVampireSH2017-03-29 22:13:12 +0800
commit88222a1265b984fc852d2877e65e05345eee3353 (patch)
tree7a9ccf4dbae4bb620074d25b3d1f1fd9fd83095a /PKGBUILD
downloadaur-88222a1265b984fc852d2877e65e05345eee3353.tar.gz
add it to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80b1db609878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sherlock Holo <sherlockya(at)gmail.com>
+
+pkgname=python-pytesseract-git
+_pkgname=pytesseract
+pkgver=17ba5c2
+pkgrel=1
+pkgdesc="A Python wrapper for Google Tesseract"
+arch=('any')
+url="https://github.com/madmaze/pytesseract"
+license=("GPL3")
+depends=('python')
+source=("git+https://github.com/madmaze/${_pkgname}.git")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "${_pkgver}%s" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+md5sums=('SKIP')