summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2020-05-23 22:30:31 -0400
committerredfish2020-05-23 22:30:31 -0400
commit8a97d893bc3a1704c919bbe63f01fa2b17c14ac4 (patch)
tree192da1e287e4cc973179ee5181b68d65882c4277 /PKGBUILD
downloadaur-8a97d893bc3a1704c919bbe63f01fa2b17c14ac4.tar.gz
1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e927798cbd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-pytest-cid
+_name=pytest_cid
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A wrapper around py-cid for writing tests involving CIDs in datastructures."
+arch=('any')
+url="https://pypi.python.org/pypi/pytest_cid"
+license=('MIT')
+depends=('python'
+ 'python-setuptools'
+ 'python-cid'
+ )
+checkdepends=()
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('61a1c282220ad1ad419cbfce7c33b3a84781be7a9edae9145da924ab2aaccfe8')