summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:22:06 +1300
committercaltlgin2020-12-03 09:22:06 +1300
commit72dd3dd7307a5ed6fd4a0e547b138085ba3f1486 (patch)
treef91de50bf7963ba17fb80ccf11c5bc07eb316c3c /PKGBUILD
parent34c2bd15c0d2e157f88686311abebbb81c6f675f (diff)
downloadaur-72dd3dd7307a5ed6fd4a0e547b138085ba3f1486.tar.gz
Python 3.9 rebuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a64c87417319..c733d16cdce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname=pytest-md-report
-pkgname=python-${_pkgname}
+_pkgname='pytest-md-report'
+pkgname="python-${_pkgname}"
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='pytest plugin to create a report in Markdown table format'
arch=('any')
url='https://github.com/thombashi/pytest-md-report'
+_url_pypi='https://pypi.org/project/pytest-md-report'
license=('MIT')
-depends=('python' 'python-pathvalidate' 'python-pytablewriter' 'python-pytest' 'python-typepy')
+depends=('python-pathvalidate'
+ 'python-pytablewriter'
+ 'python-pytest'
+ 'python-tcolorpy'
+ 'python-typepy')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('82a40db642ed25986e5b5772f10b4c61f2aa83ee8fa9cb1ae0b3cf63a72c9e28')
@@ -21,8 +26,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: