summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp A2019-01-15 15:42:00 +0100
committerPhilipp A2019-01-15 15:42:00 +0100
commita9c8aff6c97851784f240f4b7a9d81858dcbfe04 (patch)
tree5b8b05e65d6090e11bedde3a548a98464dddac44 /PKGBUILD
downloadaur-a9c8aff6c97851784f240f4b7a9d81858dcbfe04.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3cd594ec66f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=pytest-pycharm
+pkgname=python-$_name
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Plugin for pytest to enter PyCharm debugger on uncaught exceptions.'
+arch=(any)
+url="https://github.com/jlubcke/$_name"
+license=(BSD)
+depends=(python)
+makedepends=(python-pip)
+_wheel="${_name/-/_}-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('9e51c032f5c5953e65aac4b486dd7d7abe4322fc7e951328f229630b3e6bd09f')
+noextract=("$_wheel")
+
+package() {
+ cd "$srcdir"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}