summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-25 17:02:26 -0500
committerCarlos Aznarán Laos2021-11-25 17:02:26 -0500
commit2e46672b0012fab827db178c38fe74ba9ee52a8a (patch)
treed536c5d3c6dd7863f6e3351f9943315c11af92a4 /PKGBUILD
parent66b31606ed30ddb1c3f4bd8a0e9a368ea1a8a382 (diff)
downloadaur-2e46672b0012fab827db178c38fe74ba9ee52a8a.tar.gz
Version bump to 2.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 24 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62497869d780..d01b5101c138 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
-# Maintainer: Gaël Donval <gdonval+aur at google mail>
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Gaël Donval <gdonval+aur at google mail>
-
-pkgbase='python-pytest-selenium'
-pkgname='python-pytest-selenium'
-pkgver=1.3.1
+_base=pytest-selenium
+pkgname=python-${_base}
+pkgver=2.0.1
pkgrel=1
-pkgdesc='Plugin for running Selenium with py.test.'
+pkgdesc="Plugin for running Selenium with pytest"
arch=('any')
-url='https://github.com/pytest-dev/pytest-selenium'
-license=('MPL')
-makedepends=('python-setuptools')
-depends=('python>=3.3'
- 'python-pytest')
-source=("https://github.com/pytest-dev/pytest-selenium/archive/v${pkgver}.tar.gz")
-sha1sums=('500d388a0ba65465c907c4129f06778f72624e86')
-md5sums=('cb1d430b91bda33f651e5752a89734e6')
+url="https://github.com/pytest-dev/${_base}"
+license=(MPL2)
+depends=(python-pytest-base-url python-pytest-html python-pytest-variables python-selenium python-tenacity)
+makedepends=(python-setuptools-scm git)
+checkdepends=(python-pytest-localserver python-pytest-xdist python-pytest-mock) # geckodriver chromedriver
+source=("git+${url}.git?#tag=v${pkgver}")
+sha512sums=('SKIP')
build() {
- cd "${srcdir}"/pytest-selenium-$pkgver
+ cd "${_base}"
python setup.py build
}
-package_python-pytest-selenium() {
- cd "${srcdir}"/pytest-selenium-$pkgver
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m644 README.rst "${pkgdir}/usr/share/doc/${pkgname}/README"
+check() {
+ cd "${_base}"
+ python setup.py install --root="${PWD}/tmp_install" --optimize=1 --skip-build
+ PYTHONPATH="${PWD}/tmp_install$(python -c "import site; print(site.getsitepackages()[0])"):${PYTHONPATH}" python -m pytest testing -k 'not test_chrome and not test_driver and not test_firefox and not test_report and not test_safari and not invalid_host and not event_listening_webdriver'
+}
+
+package() {
+ cd "${_base}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
}