summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 00:41:54 -0500
committerCarlos Aznarán Laos2022-10-25 00:41:54 -0500
commit75e92bca6b574cb907d099326b1079a6a2d213f7 (patch)
treeae542cc7f5ef27a17c4dd751a5c10e08464c693a /PKGBUILD
parente03f2747ed7f6478ded673d14e70aa8dc21997e8 (diff)
downloadaur-75e92bca6b574cb907d099326b1079a6a2d213f7.tar.gz
Change python-install by python-installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0df768ac1dd5..16d95ebe5ad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,9 @@ arch=(any)
url="https://github.com/pytest-dev/${_base}"
license=(MPL2)
depends=(python-pytest-base-url python-pytest-html python-pytest-variables python-selenium python-tenacity)
-makedepends=(python-build python-install python-poetry-core)
+makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest-localserver python-pytest-xdist python-pytest-mock chromedriver) # geckodriver
-source=(${url}/archive/v${pkgver}.tar.gz)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('ce7d8e21974cbf6ee984189e86e5aa7127c2112f8f2469f10bfc2e18d62f490b21ab1fdf0514a9a79643d286e72eea23b53e819329d27f407f5844c7a1941665')
build() {
@@ -22,13 +22,13 @@ build() {
check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
- test-env/bin/python -m install --optimize=1 dist/*.whl
+ test-env/bin/python -m installer dist/*.whl
test-env/bin/python -m pytest testing -k 'not testingbot and not browserstack and not launch and not args and not driver_quit and not xdist and not driver_log_fixture and not launch_case_insensitive and not profile and not profile_with_preferences and not preferences_marker and not capture_debug_env[always] and not capture_debug_env[failure] and not capture_debug_config[always] and not capture_debug_config[failure] and not exclude_debug_env[url] and not exclude_debug_env[screenshot] and not exclude_debug_env[html] and not exclude_debug_env[logs] and not exclude_debug_config[url] and not exclude_debug_config[screenshot] and not exclude_debug_config[html] and not exclude_debug_config[logs] and not event_listening_webdriver'
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --destdir="${pkgdir}" dist/*.whl
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")