summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-28 10:12:14 -0500
committerCarlos Aznarán Laos2022-03-28 10:12:14 -0500
commit9375ac45b0982e2436363e2052327564075e995f (patch)
treee9b735b2c249faa761fa6d9d2804cd06a01f0f11 /PKGBUILD
parent39e926c160e231cbf52c2d637fe50325ba2ed4f9 (diff)
downloadaur-9375ac45b0982e2436363e2052327564075e995f.tar.gz
Bump version to 3.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7e6d15290f3..b9f7ba34ff7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,37 @@
# Contributor: Gaël Donval <gdonval+aur at google mail>
_base=pytest-selenium
pkgname=python-${_base}
-pkgver=2.0.1
-pkgrel=2
-pkgdesc="Plugin for running Selenium with pytest"
-arch=('any')
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="pytest plugin for Selenium"
+arch=(any)
url="https://github.com/pytest-dev/${_base}"
license=(MPL2)
depends=(python-pytest-base-url python-pytest-html python-pytest-variables python-selenium python-tenacity)
-makedepends=(python-setuptools-scm git)
-checkdepends=(python-pytest-localserver python-pytest-xdist python-pytest-mock) # geckodriver chromedriver
-source=("git+${url}.git?#tag=v${pkgver}")
-sha512sums=('SKIP')
+makedepends=(python-build python-install python-poetry-core)
+checkdepends=(python-pytest-localserver python-pytest-xdist python-pytest-mock chromedriver) # geckodriver
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('ce7d8e21974cbf6ee984189e86e5aa7127c2112f8f2469f10bfc2e18d62f490b21ab1fdf0514a9a79643d286e72eea23b53e819329d27f407f5844c7a1941665')
build() {
- cd "${_base}"
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "${_base}"
- python setup.py install --root="${PWD}/tmp_install" --optimize=1 --skip-build
- PYTHONPATH="${PWD}/tmp_install$(python -c "import site; print(site.getsitepackages()[0])"):${PYTHONPATH}" python -m pytest testing -k 'not test_chrome and not test_driver and not test_firefox and not test_report and not test_safari and not invalid_host and not event_listening_webdriver'
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m install --optimize=1 dist/*.whl
+ test-env/bin/python -m pytest testing -k 'not launch and not args and not driver_quit and not xdist and not driver_log_fixture and not launch_case_insensitive and not profile and not profile_with_preferences and not preferences_marker and not capture_debug_env[always] and not capture_debug_env[failure] and not capture_debug_config[always] and not capture_debug_config[failure] and not exclude_debug_env[url] and not exclude_debug_env[screenshot] and not exclude_debug_env[html] and not exclude_debug_env[logs] and not exclude_debug_config[url] and not exclude_debug_config[screenshot] and not exclude_debug_config[html] and not exclude_debug_config[logs] and not event_listening_webdriver'
}
package() {
- cd "${_base}"
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}