summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2020-11-17 12:53:30 +0100
committerXiretza2020-11-17 12:53:30 +0100
commit5db0ef6507eef46134973dd1d8b606dbc8cb8bcb (patch)
tree27a74d8990ea77037c5bbd29b51c0cf36a87922d /PKGBUILD
downloadaur-python-pythondata-cpu-picorv32-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db0bd54c097e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_srcname=pythondata-cpu-picorv32
+pkgname="python-$_srcname-git"
+pkgver=2020.08.r1.g8bdce32
+pkgrel=1
+pkgdesc="Python module containing verilog files for picorv32 cpu (for use with LiteX)"
+arch=(any)
+url="https://github.com/litex-hub/pythondata-cpu-picorv32"
+license=('ISC')
+depends=(python)
+makedepends=(git python-setuptools)
+provides=("${pkgname%%-git}=$pkgver")
+conflicts=("${pkgname%%-git}")
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_srcname"
+ python setup.py build
+}
+
+package() {
+ cd "$_srcname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set et ts=2 syntax=PKGBUILD: