summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsomini2020-08-22 13:17:17 +0100
committersomini2020-08-22 13:17:17 +0100
commitb7feda5c2c5eacdca3eb0d3ab82cabfcfc2d5d6a (patch)
treeefd2e368ef43685895c61b10b3269d3ff98d70e8 /PKGBUILD
downloadaur-b7feda5c2c5eacdca3eb0d3ab82cabfcfc2d5d6a.tar.gz
Initial Packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da814ce88cd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: somini <dev@somini.xyz>
+
+pkgbase=python-pythumbnailer
+pkgname=python-pythumbnailer
+_module='pythumbnailer'
+pkgver=0.3
+pkgrel=1
+pkgdesc="Create static HTML galleries with thumbnails"
+url="https://gitlab.com/somini/pythumbnailer/"
+depends=('python' 'python-argparse-utils')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('a6bf3bea6ae2fe31391c7016b417144633a68e5cb08ccd0eda23779b55944927')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}