summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Zhang2017-08-09 21:00:06 +0800
committerStephen Zhang2017-08-09 21:00:06 +0800
commit534517aed4bb2032f61a2d89e2459c15b72a58bd (patch)
tree7b597e5a17e4da0d30216e640810b14a3b4011d4 /PKGBUILD
parent6562b383e48e0ad75197db92b0919600589cd20f (diff)
downloadaur-534517aed4bb2032f61a2d89e2459c15b72a58bd.tar.gz
remove -fno-plt FLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6aff5debd0cb..f0d287f41801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase="python-pytorch"
pkgname=("python-pytorch" "python2-pytorch")
_pkgname="pytorch"
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
arch=('x86_64')
url="http://pytorch.org"
@@ -35,6 +35,8 @@ build() {
cd "$srcdir/${_pkgname}-${pkgver}-py2"
CC=gcc-5 \
CXX=g++-5 \
+ CFLAGS="${CFLAGS/-fno-plt/}" \
+ CXXFLAGS="${CXXFLAGS/-fno-plt/}" \
WITH_CUDA=1 \
CUDA_HOME=/opt/cuda \
WITH_CUDNN=1 \
@@ -46,6 +48,8 @@ build() {
cd "$srcdir/${_pkgname}-${pkgver}"
CC=gcc-5 \
CXX=g++-5 \
+ CFLAGS="${CFLAGS/-fno-plt/}" \
+ CXXFLAGS="${CXXFLAGS/-fno-plt/}" \
WITH_CUDA=1 \
CUDA_HOME=/opt/cuda \
WITH_CUDNN=1 \