summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Zhang2017-08-09 03:37:04 +0800
committerStephen Zhang2017-08-09 03:37:04 +0800
commit6562b383e48e0ad75197db92b0919600589cd20f (patch)
tree9ce63bf61c8556a586f11ff133de4875279fa43d /PKGBUILD
parent7fb1b225d53cb328a8c727d93698a154f979f2ac (diff)
downloadaur-6562b383e48e0ad75197db92b0919600589cd20f.tar.gz
fix error when building gloo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70d638c39853..6aff5debd0cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,18 +20,14 @@ sha256sums=('22b30638536d20d387e1adff62aa4b9ddebd8ac7ab812a36c699d72df9f7f570')
prepare() {
cd "$srcdir/"
+ cd "${_pkgname}-${pkgver}"
# Uncomment and modify these lines to enable Intel MKL support
- #cd "${_pkgname}-${pkgver}"
#sed -i -e '59i-DINTEL_MKL_DIR="/opt/intel/mkl" \\' torch/lib/build_all.sh
#sed -i -e '86d' -e '89d' torch/lib/TH/cmake/FindMKL.cmake
- #cd ..
+ sed -i -e '144icp -r nccl gloo/third-party/' torch/lib/build_all.sh
+ cd ..
cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
- cd "${_pkgname}-${pkgver}"
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
}
build() {