summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Zhang2017-08-09 02:28:25 +0800
committerStephen Zhang2017-08-09 02:28:25 +0800
commit7fb1b225d53cb328a8c727d93698a154f979f2ac (patch)
tree3d3f9ed2fa6918cd843a800e26aa1ad63cca54fe /PKGBUILD
parent0c38c467c2e38b2d75166aa47f72b6721f248b29 (diff)
downloadaur-7fb1b225d53cb328a8c727d93698a154f979f2ac.tar.gz
update package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c36a1c845164..70d638c39853 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase="python-pytorch"
pkgname=("python-pytorch" "python2-pytorch")
_pkgname="pytorch"
-pkgver=0.1.12
+pkgver=0.2.0
pkgrel=1
pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration"
arch=('x86_64')
@@ -14,12 +14,18 @@ makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools'
'gcc5' 'cmake')
depends=('cuda' 'cudnn')
source=("https://github.com/pytorch/pytorch/archive/v${pkgver}.tar.gz")
-sha256sums=('ace32cc277c2f59b1e496e326bf504d800061edde9b6c2af29bbb2f08728ca30')
+sha256sums=('22b30638536d20d387e1adff62aa4b9ddebd8ac7ab812a36c699d72df9f7f570')
prepare() {
cd "$srcdir/"
+ # Uncomment and modify these lines to enable Intel MKL support
+ #cd "${_pkgname}-${pkgver}"
+ #sed -i -e '59i-DINTEL_MKL_DIR="/opt/intel/mkl" \\' torch/lib/build_all.sh
+ #sed -i -e '86d' -e '89d' torch/lib/TH/cmake/FindMKL.cmake
+ #cd ..
+
cp -a "${_pkgname}-${pkgver}" "${_pkgname}-${pkgver}-py2"
cd "${_pkgname}-${pkgver}"
sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \