summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenoit Brummer2024-05-02 16:09:32 +0200
committerBenoit Brummer2024-05-02 16:09:32 +0200
commit6cda169ba4bdcd6a95cbe076855951e02bbbbe25 (patch)
treeaec10f19cdc5c5d6f3986162320e41e93623bf3d /PKGBUILD
parent7e35d41f484a173a3195dbda5eca9f2137cc9e23 (diff)
downloadaur-6cda169ba4bdcd6a95cbe076855951e02bbbbe25.tar.gz
add --ignore-installed flag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0b7bf320d18..81af242dfcf9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=('python-pytorch-rocm-bin')
pkgdesc="Tensors and Dynamic neural networks in Python with strong GPU acceleration (binary release)"
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
url="https://pytorch.org"
license=('BSD')
arch=('x86_64')
@@ -23,6 +23,6 @@ package() {
cd "${srcdir}"
# Install the wheel file
- python -m pip install --no-deps --root="${pkgdir}" torch-${pkgver}%2Brocm6.0-cp312-cp312-linux_x86_64.whl --break-system-packages --no-warn-script-location
+ python -m pip install --no-deps --root="${pkgdir}" torch-${pkgver}%2Brocm6.0-cp312-cp312-linux_x86_64.whl --break-system-packages --no-warn-script-location --ignore-installed
ln -sf /usr/lib/libgomp.so ${pkgdir}/usr/lib/python3.12/site-packages/torch/lib/libgomp.so
}