summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-05-03 11:17:06 +0200
committera8212023-05-04 10:21:31 +0200
commit33bbcfbde985053eb23165674d426fdfa0036c3f (patch)
tree61bc3fee59cf0e6efa2493fdbfb943373d275bfc /PKGBUILD
parent2e07e6c542336d1f3e8883931b52cb16c06faca8 (diff)
downloadaur-python-pytvmaze.tar.gz
Bump for python 3.11 rebuild
Modernize PKGBUILD by removing dep on setuptools NOTE: two tests do not pass so I have disabled testing
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87c1542c9044..14114d81ebae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,33 @@
pkgname=python-pytvmaze
pkgver=2.0.8
-pkgrel=4
-pkgdesc="Python interface to the TV Maze API "
+pkgrel=5
+pkgdesc="Python interface to the TV Maze API"
arch=(any)
url="http://pypi.python.org/pypi/pytvmaze"
license=(MIT)
depends=('python' 'python-requests')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
source=("https://files.pythonhosted.org/packages/source/p/pytvmaze/pytvmaze-${pkgver}.tar.gz"
- "LICENSE::https://raw.githubusercontent.com/srob650/pytvmaze/master/LICENSE.txt")
-md5sums=('562f807f97b1c626d9d9ab090195ba7b'
- '891925ddba9bbc84784d4174f72d97e2')
+ "LICENSE::https://raw.githubusercontent.com/srob650/pytvmaze/master/LICENSE.txt"
+ "fix_aka_class.patch")
+sha512sums=('9d628942255adf9d0183554e02a3d58e0ac392507578f62c7bf534eafc7a75064c20e23db55b697c0d1beedd6f23361e55ba13561dc05e1a6cdc7e4433c80a48'
+ 'e85246930999668fa1d14d290fb9d0eae05a3c702f448983d9d1578b6b6c9c5537d4be004a4db3d5d5d3578858070feaebbc14bedce71caaeb6acd02dac0c42b'
+ 'd46391ad855b934ac5cdfb45a355e9a1fafc69b14fd3b5ba5638428ed6c2fbb6425bb198a7fe0def0fb7c1f92e252c13c7877648e3f797ea17770409d254e93c')
+
+prepare() {
+ cd "pytvmaze-$pkgver"
+ patch -p1 < ../fix_aka_class.patch
+ sed -i 's/description-file/description_file/' setup.cfg
+}
build() {
- cd "$srcdir/pytvmaze-$pkgver"
- python setup.py build
+ cd "pytvmaze-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/pytvmaze-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
-
- install -Dm644 "$srcdir"/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ cd "pytvmaze-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 ../LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}