summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-06 13:49:02 -0500
committerCarlos Aznarán Laos2022-10-06 13:49:02 -0500
commite2a42a079867ec8664c42a26de881a6b5c6e3b34 (patch)
treedf6db80fa9b5099e4d3f4a6a77c289ff369d2e5e /PKGBUILD
parent07aa8c81eb57e1a0440b6e5198e0c1afd588203e (diff)
downloadaur-e2a42a079867ec8664c42a26de881a6b5c6e3b34.tar.gz
Fix jupyter extension
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8755d474c297..549826acdc81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,27 @@
_base=pyviz_comms
pkgname=python-${_base}
pkgver=2.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Bidirectional communication for the PyViz ecosystem'
arch=(any)
url="https://github.com/pyviz/${_base}"
license=('custom:BSD-3-clause')
makedepends=(python-setuptools)
-depends=(python-param)
-# checkdepends=(python-pytest flake8)
+depends=(python-param jupyterlab)
+checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('7c64a9923483a0f73cc3c877b4d02b2c5dd5a90382bf7ae2f564125e14e35a3f2eac9a0a995fa502f34ac91e809986f1e58cb2c9b98c7ca6262682a37a9aea9e')
build() {
cd ${_base}-${pkgver}
python setup.py build
+ jlpm
}
-# check() {
-# cd ${_base}-${pkgver}
-# python -m pytest
-# }
+check() {
+ cd ${_base}-${pkgver}
+ python -m pytest
+}
package() {
cd ${_base}-${pkgver}