summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122024-03-10 18:04:15 +0100
committerwillemw122024-03-10 18:04:15 +0100
commit0fe9a1261fc01dbbc4346bad2c2f54621ef47122 (patch)
tree19683e60d5d307b95c6fb0e8d0f8d978ec6f35d5 /PKGBUILD
parent1b84a4f3f03f675ba5113b63bf3c53a7629f6683 (diff)
downloadaur-0fe9a1261fc01dbbc4346bad2c2f54621ef47122.tar.gz
Update to standards based install
Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3b2d7fe442a..55aacecc1fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=python-pywapi-git
pkgver=r126.7f05282
-pkgrel=1
-pkgdesc="Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs"
-arch=('any')
-url="https://launchpad.net/python-weather-api"
-license=('MIT')
-depends=('python')
-makedepends=('git')
+pkgrel=2
+pkgdesc='Python wrapper around the Yahoo! Weather, Weather.com and NOAA APIs'
+arch=(any)
+url=https://launchpad.net/python-weather-api
+license=(MIT)
+depends=(python)
+makedepends=(git python-build python-installer python-wheel python-setuptools)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
#source=($pkgname::git+https://github.com/khurshid-alam/python-weather-api.git)
-source=($pkgname::git+https://git.launchpad.net/~khurshid-alam/python-weather-api/+git/trunk)
-md5sums=('SKIP')
+source=("$pkgname::git+https://git.launchpad.net/~khurshid-alam/python-weather-api/+git/trunk")
+sha256sums=('SKIP')
pkgver() {
cd $pkgname
@@ -22,12 +22,11 @@ pkgver() {
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-