summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShae2023-07-16 00:51:54 -0700
committerShae2023-07-16 00:51:54 -0700
commit3b3aecd80e8a9d2a1d2722a40286e152e024464b (patch)
tree995c01768f7e6202f60d21225867148837274876 /PKGBUILD
parent9357703334a8d0ad1079fe59750763ce46215002 (diff)
downloadaur-3b3aecd80e8a9d2a1d2722a40286e152e024464b.tar.gz
Updated to newest release, replacing setup.py install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b601a4581e2..c14e1cc9fb63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Shae VanCleave
pkgname=python-pywebview
-pkgver=4.1
+pkgver=4.2.2
pkgrel=1
pkgdesc="Build GUI for your Python program with JavaScript, HTML, and CSS."
arch=('any')
url='https://github.com/r0x0r/pywebview'
license=('BSD')
depends=('python' 'python-proxy_tools' 'python-bottle')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=('python-gobject: use with GTK'
'python-cairo: use with GTK'
'webkit2gtk>=2.22: use with GTK'
@@ -21,17 +21,17 @@ optdepends=('python-gobject: use with GTK'
install="$pkgname.install"
source=("https://pypi.python.org/packages/source/p/pywebview/pywebview-$pkgver.tar.gz"
"https://raw.githubusercontent.com/r0x0r/pywebview/master/LICENSE")
-sha256sums=('62efa24fff0b35fb8028556b6d44fc1c698a1deefa8df2c5557909af54679450'
+sha256sums=('85be4215cd65ceacca5c7faef9d271e10bfe3ca25d2498c1c6d2e59a4d56e86c'
'4a988dd3598832cd3653de20dc33cb677d0fb53ab5551c879ca31280ae653675')
build() {
cd "${srcdir}/pywebview-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}"
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd "pywebview-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}