summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2023-02-09 14:00:08 +0100
committerKokaKiwi2023-02-09 14:00:08 +0100
commit55294354719fc9329340fb67e7a7aea8c1316a83 (patch)
tree95f23995e2d7b83a201f30d80a7c879cbe368df5 /PKGBUILD
parenta08a019d6329cc707070165e8eaae24469f88eff (diff)
downloadaur-55294354719fc9329340fb67e7a7aea8c1316a83.tar.gz
upgpkg: python-qbittorrent-api 2023.2.41-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1b358134ef9..af1987f46d2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
_pkgname=qbittorrent-api
pkgname="python-$_pkgname"
-pkgver=2022.11.40
-pkgrel=2
+pkgver=2023.2.41
+pkgrel=1
pkgdesc="Python client for qBittorrent v4.1+ Web API"
arch=('any')
url="https://pypi.org/project/$_pkgname"
license=('MIT')
depends=('python' 'python-requests' 'python-urllib3' 'python-six')
makedepends=('python-build' 'python-installer' 'python-wheel')
-checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::https://github.com/rmartin16/qbittorrent-api/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('e57a5ba7277625895f4e7445983aa8e22d65577831f6eb328e2926f7bf4e5b17')
-b2sums=('2ae706e4f6b1b6ac237814d9c7de09a3fa743928dfc2da199abc03e49309788b1fecfb0367ffd480a020e65b84084bb94687a3d803ff350fdffec35f3ac69069')
+sha256sums=('be7ee3e4cfa72210194772021c528b0adc09d6025e4ea15ed987f5bebab16d00')
+b2sums=('95e5003dca76c814fbf2cf44edb14389749f4c5c3e892afc2e761d914ef4181f10b45fd60b9d53185e037be3a9d2a5ead54f470d3bb42447b8fbc10153ce07ca')
build() {
cd "$_pkgname-$pkgver"
@@ -21,15 +20,6 @@ build() {
python -m build --wheel --no-isolation
}
-check() {
- cd "$_pkgname-$pkgver"
-
- # Not working for now because of some broken code
- # when packaging
-
- # pytest
-}
-
package() {
cd "$_pkgname-$pkgver"