summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKokaKiwi2022-03-13 14:33:19 +0100
committerKokaKiwi2022-03-13 14:33:19 +0100
commit68e703022e01bc9a8e4779f643fb4de857ae539d (patch)
tree9e3a42211febee5241271671d8a4352946596e47 /PKGBUILD
downloadaur-68e703022e01bc9a8e4779f643fb4de857ae539d.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfad0a2d84f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+_pkgname=qbittorrent-api
+pkgname="python-$_pkgname"
+pkgver=2022.2.28
+pkgrel=1
+pkgdesc="Python client for qBittorrent v4.1+ Web API"
+arch=('any')
+url="https://pypi.org/project/$_pkgname"
+license=('MIT')
+depends=('python' 'python-requests' 'python-urllib3' 'python-six')
+makedepends=('python-setuptools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rmartin16/qbittorrent-api/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('535e2158a5dfeb58453ed50e22ce72adb3de086eafcc7f7d5c3b1401ec0ecb6f')
+b2sums=('0b5e63edf67d84430d70165516d82fc3ff47d6a2e85424f4ad5db912208e209c465bb938680e6e249ec2ee1fa1ac3723f81e66ef2f174b34cad9af92568ca0e5')
+
+build() {
+ cd "$_pkgname-$pkgver"
+
+ python setup.py build
+}
+
+check() {
+ cd "$_pkgname-$pkgver"
+
+ export PYTHONPATH="build/lib"
+ python setup.py test
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}