summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClaudia Pellegrino2024-04-28 15:15:27 +0200
committerClaudia Pellegrino2024-04-28 15:19:50 +0200
commitb9a8413eb1423c8c799645672421259ef446f5d0 (patch)
tree3539b92ba20cc5971a13d5ca5f212dc4f9725845 /PKGBUILD
parentdfc4dd3b02ae3aaa79d37c6a208d7133dc342ba9 (diff)
downloadaur-python-qhue.tar.gz
Use PEP 517 for building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e39a02249328..92b14743b36f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,30 @@
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_pkgname=qhue
-pkgbase=python-qhue
pkgname='python-qhue'
pkgdesc='A very lightweight Python wrapper to the Philips Hue API'
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
arch=('any')
url='https://github.com/quentinsf/qhue'
-license=('GPL2')
+license=('GPL-2.0-only')
depends=('python' 'python-requests' 'python-requests-oauthlib')
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
optdepends=('python-yaml: debug print API responses')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('bc35fd6388e1613e67af3c034bbfef6196fc0187d9c6d85aac924776c0e08dcd636f5bcc4ee46b3e429795e68843bd5145eb6e4978c3c84617ad851ce4a11a2d')
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ python -I -m installer --destdir="${pkgdir}" dist/*.whl
}