summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicoHood2020-06-09 23:38:46 +0200
committerNicoHood2020-06-09 23:38:46 +0200
commitce1b6f6846ab150cc30af36d401d42cdf316cad2 (patch)
tree76163742e40797014e23515859fa39c0ef2b50fa /PKGBUILD
parentfd29da9cb58842c250afc95248d8d317a6571ce2 (diff)
downloadaur-ce1b6f6846ab150cc30af36d401d42cdf316cad2.tar.gz
Added GPG verification
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7a6fb0df800..4e769d162b31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,11 @@ arch=('any')
url="https://github.com/quentinsf/qhue"
license=('GPL2')
makedepends=('python-setuptools' 'python2-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('11ea0f9853dd0e26ecae0d6bd22b45f68ba1b19e6bd01379b2a2c67fd80bd1c4f5db9a34d988248b6111b3ea5bba71eddcc5a8390aea16a09e05c4b749a019d0')
-validpgpkeys=('') # TODO https://github.com/quentinsf/qhue/issues/19
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/quentinsf/${_pkgname}/archive/${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz.asc::https://github.com/quentinsf/${_pkgname}/releases/download/${pkgver}/qhue-${pkgver}.tar.gz.asc")
+sha512sums=('11ea0f9853dd0e26ecae0d6bd22b45f68ba1b19e6bd01379b2a2c67fd80bd1c4f5db9a34d988248b6111b3ea5bba71eddcc5a8390aea16a09e05c4b749a019d0'
+ 'SKIP')
+validpgpkeys=('36F2083F293ED4FD83847B8309328E8BF9464B5F')
prepare() {
# Create a copy for the python2 package