summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornullableVoidPtr2022-06-16 02:17:28 +0800
committernullableVoidPtr2022-06-16 02:17:28 +0800
commite766ee133109a27f7e73d47ef8d8bc6afff2c62b (patch)
treeae38a964c221ca9b577b6c40d1687a816e09fbc7 /PKGBUILD
parentb550b5f6073ceb187e063e5d199f6b8a0c0a7370 (diff)
downloadaur-e766ee133109a27f7e73d47ef8d8bc6afff2c62b.tar.gz
Bump version and install license file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 192864774e6d..a8b93bc6c2a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
pkgname=python-qiling
_name=${pkgname#python-}
-pkgver=1.4.2
+pkgver=1.4.3
pkgrel=1
pkgdesc="An advanced binary emulation framework"
url='https://qiling.io/'
-arch=('x86_64')
+arch=('any')
license=('GPL2')
-depends=('python' 'python-capstone' 'python-unicorn' 'python-pefile' 'python-registry' 'python-keystone' 'python-pyelftools' 'python-gevent' 'python-multiprocess' 'python-yaml>=6.0') # Community is not up to date on pyyaml! Use python-yaml-git or testing/!
+depends=('python' 'python-capstone' 'python-unicorn' 'python-pefile' 'python-registry' 'python-keystone' 'python-pyelftools' 'python-gevent' 'python-multiprocess' 'python-yaml')
makedepends=('python-setuptools')
source=(https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz)
-sha256sums=('9b2506ccd3f86dff74776818e599586d59531bae34763fd085af3f68cc9dbeec')
+sha256sums=('b277512a49df6372e0a947fa14ea1bc1ccc84ad8f3664b9d560511d44412c9e5')
build() {
cd "${_name}-${pkgver}"
@@ -22,4 +22,5 @@ package() {
cd "${_name}-${pkgver}"
export PYTHONHASHSEED=0
python setup.py install --root="${pkgdir}" -O1 --skip-build
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}