summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornullableVoidPtr2021-02-22 15:44:58 +0800
committernullableVoidPtr2021-02-22 15:44:58 +0800
commit7c1bce4063bed36bdb13ce34114cdc0672f0dfb5 (patch)
tree80d16677716bc642f29e08eb232c1c3c1ea29a16 /PKGBUILD
parent8b402f40a651bac73f382ebabf789422a79186c3 (diff)
downloadaur-7c1bce4063bed36bdb13ce34114cdc0672f0dfb5.tar.gz
Fix tests so no external files are required
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c66041ec408..3a38354a2db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: nullableVoidPtr <nullableVoidPtr _ gmail _ com>
pkgname=python-qiling-git
-pkgver=1.2.r215.g3e31db68
-pkgrel=4
+pkgver=1.2.2.r62.ge4f07cf1
+pkgrel=1
pkgdesc="An advanced binary emulation framework"
url='https://qiling.io/'
arch=('x86_64')
@@ -34,5 +34,11 @@ package() {
check() {
cd "${srcdir}/${pkgname}/tests"
- ./test_elf.sh
+ python3 ./test_posix.py &&
+ python3 test_elf_multithread.py &&
+ python3 test_android.py &&
+ python3 ./test_debugger.py &&
+ python3 ./test_uefi.py &&
+ python3 ./test_shellcode.py &&
+ python3 ./test_edl.py
}