summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2022-02-08 22:01:13 +0100
committerIyán Méndez Veiga2022-02-08 22:01:13 +0100
commit214a26ccc829c5db4b7b5c014cfdd8daafa7bf88 (patch)
tree71cfcf929549916b1f50d1c637d7d6fe209ffe44 /PKGBUILD
parentc1549fc9cabfc061c1fcee0f17ad0e26a951e805 (diff)
downloadaur-214a26ccc829c5db4b7b5c014cfdd8daafa7bf88.tar.gz
Update to 0.10.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df4f56b91cf0..b1ceaaaea547 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-aer
pkgname=python-${_pkgname}
-pkgver=0.8.2
-pkgrel=3
+pkgver=0.10.2
+pkgrel=1
pkgdesc="A high performance simulator for quantum circuits that includes noise models"
arch=('x86_64')
url="https://github.com/Qiskit/qiskit-aer"
@@ -11,17 +11,16 @@ depends=(
'cython'
'muparserx'
'nlohmann-json'
- 'openblas-lapack'
'python-numpy'
'python-qiskit-terra'
'python-scipy'
- 'spdlog'
)
optdepends=(
'cuda: Parallelization with CUDA (NVIDIA)'
'intel-tbb: Parallelization with Intel TBB'
'openmp: Parallelization with OpenMP'
'thrust: Parallelization (GPU/CPU) support'
+ 'python-dask: Parallel computing'
)
makedepends=(
'cmake'
@@ -29,10 +28,11 @@ makedepends=(
'python-pip'
'python-scikit-build'
'python-setuptools'
+ 'spdlog'
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('bcf0ae0a00a44e3887d2f0ced083e1c27c916a73d29a61b08de63f3aa2a157a1')
+sha256sums=('039c99349e012a1248dedd40c2e14f5f1616b52d6cc94ab05e16e4f2c8c7f121')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
@@ -42,4 +42,8 @@ build() {
package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ # This deletes all folders except /usr/lib/python3.10/site-packages/qiskit/
+ # See https://github.com/Qiskit/qiskit-aer/issues/1457
+ find "${pkgdir}/usr" -mindepth 1 -maxdepth 1 -not -name lib -exec rm -rf '{}' \;
}