summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2021-04-29 22:12:00 +0200
committerIyán Méndez Veiga2021-04-29 22:12:00 +0200
commit575cd47f0c6533ea541084821fd9ae90307cf640 (patch)
tree804ec252ea0fc04f6e49a46346af56db744f3352 /PKGBUILD
parenta3fa2f844657af903672c55d3ffb4db2702a7394 (diff)
downloadaur-575cd47f0c6533ea541084821fd9ae90307cf640.tar.gz
Update to 0.8.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1890220d967b..add5b0336da9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,45 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-aer
pkgname=python-${_pkgname}
-pkgver=0.7.6
+pkgver=0.8.2
pkgrel=1
pkgdesc="A high performance simulator for quantum circuits that includes noise models"
arch=('x86_64')
url="https://github.com/Qiskit/qiskit-aer"
license=('Apache')
depends=(
- 'python-qiskit-terra'
'cython'
+ 'muparserx'
+ 'nlohmann-json'
'openblas'
+ 'python-numpy'
+ 'python-qiskit-terra'
+ 'python-scipy'
'spdlog'
- 'muparserx')
+)
optdepends=(
- 'thrust: Parallelization (GPU/CPU) support'
'cuda: Parallelization with CUDA (NVIDIA)'
+ 'intel-tbb: Parallelization with Intel TBB'
'openmp: Parallelization with OpenMP'
- 'intel-tbb: Parallelization with Intel TBB')
+ 'thrust: Parallelization (GPU/CPU) support'
+)
makedepends=(
- 'python-setuptools'
- 'python-pip'
'cmake'
+ 'pybind11'
+ 'python-pip'
'python-scikit-build'
- 'pybind11')
-source=(
- "${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
+ 'python-setuptools'
+)
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('ded2d0ac38fb522420db6b36f403b7182f9cee9e9150c711a0711837a17da3f1')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- DISABLE_CONAN=ON python setup.py build
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ DISABLE_CONAN=ON python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
}