summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2021-03-14 18:33:01 +0100
committerIyán Méndez Veiga2021-03-14 18:33:01 +0100
commita3fa2f844657af903672c55d3ffb4db2702a7394 (patch)
tree326856a3b0d47e406685d94b8d0f112ee132af7c /PKGBUILD
parent328c92633e632e4e33d16e018dc290de25d04eff (diff)
downloadaur-a3fa2f844657af903672c55d3ffb4db2702a7394.tar.gz
Update to 0.7.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4d1476be63e..1890220d967b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=qiskit-aer
pkgname=python-${_pkgname}
-pkgver=0.7.1
-pkgrel=2
+pkgver=0.7.6
+pkgrel=1
pkgdesc="A high performance simulator for quantum circuits that includes noise models"
arch=('x86_64')
url="https://github.com/Qiskit/qiskit-aer"
@@ -11,7 +11,8 @@ depends=(
'python-qiskit-terra'
'cython'
'openblas'
- 'pybind11')
+ 'spdlog'
+ 'muparserx')
optdepends=(
'thrust: Parallelization (GPU/CPU) support'
'cuda: Parallelization with CUDA (NVIDIA)'
@@ -19,17 +20,18 @@ optdepends=(
'intel-tbb: Parallelization with Intel TBB')
makedepends=(
'python-setuptools'
- 'conan'
+ 'python-pip'
'cmake'
- 'python-scikit-build')
+ 'python-scikit-build'
+ 'pybind11')
source=(
"${_pkgname}-${pkgver}.tar.gz::https://github.com/Qiskit/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('816e0adaef2a5b89f0efa10c8b947815dbb09cbdbc0ad55282e08d07dcc99436')
+sha256sums=('ded2d0ac38fb522420db6b36f403b7182f9cee9e9150c711a0711837a17da3f1')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ DISABLE_CONAN=ON python setup.py build
}
package() {